Anmelden
Ich möchte für die nächsten 30 Tagen angemeldet bleiben
Deutsch
Several pages in the usergroup are available in English. Click on english to visit these pages.
Druckerfreundlich ModuleActions mit Sigma Icons
Sortieren:
Vorheriger BeitragVorheriger Beitrag Nächster BeitragNächster Beitrag
Sie sind nicht autorisiert, um eine Antwort zu erstellen.
Autor Nachrichten
Simon HostettlerBenutzer ist Offline
Beiträge: 40
New Member


--
27 Feb 2012 17:09
Guten Tag

Ich habe nichts zu diesem Thema gefunden und denke es ist ein DNN 6 Bug sein.

Beim Getter der Methode ModuleActions kann man die neue API für das Thumbnails benutzten aber in der Darstellung erscheint das Icon im DropDown des Manage Buttons nicht.

Code welcher nicht funktioniert:

Actions.Add(GetNextActionID(), Localization.GetString("EditModule", this.LocalResourceFile), DotNetNuke.Entities.Modules.Actions.ModuleActionType.AddContent, "", DotNetNuke.Entities.Icons.IconController.IconURL("Users"), EditUrl(), false, SecurityAccessLevel.Edit, true, false);

Code welcher funktnioniert:

Actions.Add(GetNextActionID(), Localization.GetString("EditModule", this.LocalResourceFile), DotNetNuke.Entities.Modules.Actions.ModuleActionType.AddContent, "", "../../Icons/Sigma/Users_16x16_Standard.png", EditUrl(), false, SecurityAccessLevel.Edit, true, false);

Der Pfad beim ersten Code ist falsch. Es wird immer mit /images gestartet und nicht mit /icons!!!!

Kann jemand das Problem nachvollziehen?
Sie sind nicht autorisiert, um eine Antwort zu erstellen.

Active Forums 4.2
NOT LICENSED FOR PRODUCTION USE
www.activemodules.com